Back to overview
Resolved

Emergency Security Maintenace

Aug 9, 2026 at 3:30pm UTC  –  Aug 9, 2026 at 4:15pm UTC
Affected services
Billing Portal
Game Panel
DE-FRA-01

Resolved
Aug 9, 2026 at 4:15pm UTC

Maintenance ended

Updated
Aug 9, 2026 at 4:15pm UTC

Maintenance has ended!

Created
Aug 9, 2026 at 3:30pm UTC

We are performing emergency maintenance to address a critical security issue and protect our hosting infrastructure and customer services.

During this process, all services may be temporarily unavailable. We are working to complete the restart as quickly as possible and restore full service.

We apologize for the unexpected downtime and appreciate your patience and understanding.