We will be performing scheduled maintenance on our Game Panel, and NL-AMS-01 Game Server.
Resolved
Mar 25, 2026 at 2:22pm UTC
Maintenance over!
Affected services
Updated
Mar 25, 2026 at 1:36pm UTC
The entire routing system was blown up, but we have successfully fixed it. Additionally, we have integrated third-party addons into our Game Panel.
Affected services
Updated
Mar 25, 2026 at 12:03pm UTC
The addon pack has been installed to complement and enhance the theme. We will be moving on adding our other addons to make the Game Panel more customizable.
Affected services
Updated
Mar 25, 2026 at 11:58am UTC
We have updated our Game Panel, as well as, added back the theme we use.
Affected services
Created
Mar 25, 2026 at 11:30am UTC
During this maintenance window, the Game Panel and NL-AMS-01 (Amsterdam, Netherlands Game Server) will be temporarily unavailable.
This update includes:
- System Improvements
- Bug Fixes
- Performance Increase
- New features
This maintenance will impact the Game Panel, NL-AMS-01, and may also affect our EU database.
We will be working as hard as possible to ensure everything is back online as quickly as possible.
If you experience any issues or need assistance, please contact our support team.
Affected services