Back to overview
Maintenance

Rescheduled Maintenance

Apr 9, 2026 at 6:30am UTC  –  Apr 9, 2026 at 10:58am UTC
Affected services
Game Panel
Billing Portal
Brandon (EU Database)
NL-AMS-01

Resolved
Apr 9, 2026 at 10:58am UTC

We have successfully completed all the updates. We haven't had the chance to focus on the Billing Panel or our Database yet, but we willll take care of that at a later time. Thank you for your understanding!

Created
Apr 9, 2026 at 6:30am UTC

We will be performing emergency maintenance on our Game Panel, our Billing Panel, our Game Server (NL-AMS-01), and our Game Server Database (Brandon).

During this period, our services may be partially or fully unavailable.

This maintenance includes:
- Fixing existing panel bugs and stability issues
- Improving overall performance and load speeds
- Applying infrastructure enhancements to increase reliability

These updates are part of our efforts to deliver a smoother, faster, and more stable experience.

We appreciate your patience and understanding.