Back to overview
Resolved

Emergency Maintenance starting in 30 minutes.

Jun 20, 2026 at 4:30pm UTC  –  Jun 20, 2026 at 4:30pm UTC
Affected services
Billing Portal

Resolved
Jun 20, 2026 at 4:30pm UTC

Maintenance ended.

Created
Jun 20, 2026 at 4:30pm UTC

Unfortunately, we will be performing emergency maintenance on our Billing Panel and migrating it to a new node.