Back to overview
Resolved

Emergency Maintenance starting in 1 hour.

Jun 21, 2026 at 9:45am UTC  –  Jun 21, 2026 at 11:38am UTC
Affected services
Game Panel

Resolved
Jun 21, 2026 at 11:38am UTC

Everything has been migrated to the new machine!

Updated
Jun 21, 2026 at 11:38am UTC

Maintenance ended

Created
Jun 21, 2026 at 9:45am UTC

We will be transfer our Game Panel to a new machine for better reliability, and latency.